User Tools

Site Tools


dev:notes:dart

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

dev:notes:dart [2019/12/25 15:40] (current)
Line 1: Line 1:
 +# GT's Dart on Debian
 +
 +## Overview
 +
 +[[http://​dartsim.github.io/​|{{http://​dartsim.github.io/​DART%20logo.jpg?​400|DART Logo}}]]
 +
 +## Notes
 +
 +### Dependencies
 +
 +    sudo apt-get install build-essential cmake pkg-config libeigen3-dev libassimp-dev libccd-dev libfcl-dev libxi-dev libxmu-dev freeglut3-dev libflann-dev libboost-all-dev libtinyxml-dev libtinyxml2-dev liburdfdom-dev liburdfdom-headers-dev libbullet-dev libnlopt-dev coinor-libipopt-dev
 +
 +### Get the source, with last stable version
 +
 +    git clone git://​github.com/​dartsim/​dart.git
 +    cd dart
 +    git checkout tags/v4.3.4
 +
 +### Build and install from source
 +
 +    mkdir build && cd build
 +    cmake ..
 +    make -j4
 +    make install
 +
 +### Build and install a debian package
 +
 +Make the *orig* archive
 +
 +    cd ..
 +    tar czvf dart_5.0.0.orig.tar.gz dart
 +    cd dart
 +
 +You need to edit the `debian/​changelog`file to add **-1** to the version number, so it becomes `5.0.0-1`. Then, build and install:
 +
 +    debuild -us -uc
 +    cd ..
 +    sudo dpkg -i ./​libdart-core5.0_5.0.0-1_amd64.deb ​ ./​libdart5.0_5.0.0-1_amd64.deb
 +    # If you need the -dev packages:
 +    sudo dpkg -i ./​libdart-core5-dev_5.0.0-1_amd64.deb ./​libdart5-dev_5.0.0-1_amd64.deb ​
 +
 +## Resources
 +
 +* [[https://​smartech.gatech.edu/​handle/​1853/​52832|DART presentation]]
 +
 +
 +# GT's GRIP on Debian
 +
 +<note important>​Probably also broken with wxWidget3 DART5</​note>​
 +
 +## Dependencies
 +
 +    sudo aptitude install libwxbase3.0-dev libwxgtk3.0-dev
 +
 +
 +## Compile
 +
 +    sudo aptitude install ​
 +    git clone https://​github.com/​dartsim/​grip.git
 +    cd grip
 +    mkdir build && cd build
 +    cmake ..
 +    make -j4
 +
 +# GT's GRIP2 on Debian
 +
 +<note important>​Broken with DART 5</​note>​
 +
 +## Dependencies
 +
 +    sudo aptitude install libopenscenegraph-dev libqt4-dev
 +
 +
 +## Tweaks
 +
 +You need to tweak the `CMakeLists.txt`to fix the OSG lib path 
 +
 +## Compile
 +
 +    sudo aptitude install ​
 +    git clone https://​github.com/​dartsim/​grip.git
 +    cd grip
 +    mkdir build && cd build
 +    cmake ..
 +    make -j4
  
/home/share/www/redox.ws/wiki/data/pages/dev/notes/dart.txt · Last modified: 2019/12/25 15:40 (external edit)